How can we help?

Lightspeed’s Help Centre is here to provide support, tips and troubleshooting

What hardware can I use With Lightspeed Kounta?

 

Lightspeed Kounta POS is compatible with iPad, iPhone, iPod, Android devices as well as Windows and Apple Computers.

You can use one or more types of devices in a single venue. So if you want to bring hardware from your previous system or buy new, getting up and running is quick and simple!

 

Before you begin 

Buying new hardware

Using your existing hardware

 


Before you begin - You'll need a solid network

We know that it can be tricky knowing what's hot and what's not when looking at your network. So one of our Specialists put together this guide on best networking practices to help you out.

Still, need some help? It might be time to call in the cavalry. You can find a listing for our carefully selected Specialist Partners from the Lightspeed Kounta Back Office.

 

 

Buying new hardware

Before you buy new hardware we recommend you visit our hardware page which shows a few examples of what we recommend. If you would like to ask a few questions or get a quote, our team is more than happy to help. Ready to talk to an expert?

All Lightspeed Kounta features are compatible when you’re running iOS. While we provide support for Android and Chrome some features and payment integrations are incompatible.


You'll also want to check out compatibility with printers here.

 

   

Using your existing hardware

Already have a device you can use but want to make sure it won't let you down? Below are a list of the minimum requirements needed for iOS (Apple), Android and Windows devices.

iOS

For iOS devices made by Apple we recommend using these or newer devices

  • iPad Mini 4
  • iPad Air 2
  • iPad Pro - 1st Gen
  • iPhone 5S, iPod Touch - 6th Gen.

iOS 13 is the oldest supported software. If your device is older than listed or running an older version of iOS, we recommend updating or replacing your devices to avoid stability issues.

Please note that the iOS app has the most support for our various add-ons and features.


Android

Lightspeed has an app that is compatible with Android, it is tested and has full support on the following devices.

  • Samsung Galaxy Tab A (SM-T380)
  • Samsung Galaxy Tab A 10" (SM-T510)
  • Xiaomi Mi Pad 4 (MI PAD 4)
  • Samsung Galaxy S9 (SM-G960F)
  • Google Pixel 4XL

Other devices should be compatible if they meet these specifications; but please note there can be hardware limitations on certain devices beyond our control.

  • Quad-Core 1.8GHz Processor 
  • Android 10 or higher*
  • 2GB of RAM (minimum)
  • Must be a Google Play Services compatible device

* = Please note that 'Android Go' and other cut-down versions of Android are not supported.
Lightspeed POS is also only available on the Google Play store and will not be made available on any alternative storefronts nor will the .apk file be made available.


icon_windows.png

Browser Compatibility - Lightspeed Kounta is developed and optimised for use with Google Chrome. Best if you make sure you have the latest version.

 

Prefer to use a combination of any of the above? Well, you can.

Simply make sure each device meets the minimum recommended requirements above.

 

Pro Tip -  If you are planning  on using a Windows or Mac computer for any of your POS then, you will need to use the Intelligent printing method

 

 


Next step? Setting up your Hardware

Browse more topics

Was this article helpful?
13 out of 25 found this helpful